Como muchos saben, una de las tradiciones de Ubuntu Life es la de publicar a los poco días del lanzamiento de una nueva versión de Ubuntu, un “poderoso” popurrí en el desglosa paso a paso las aplicaciones “básicas” que hay que instalar en Ubuntu, no sólo para hacerlo 100% funcional sino para que puedas “apantallar” a propios y extraños  con tu computadora, sin embargo este año he decidido que en lugar de esperar, puedo modificar el post que se hizo para Karmic Koala, obviamente haciendo las modificaciones pertinentes para Lucid Lynx, así que comencemos:

Primero que nada un par de advertencias para los “recién llegados” a Ubuntu, y porque no, para todos los usuarios, ya que nunca está de más: les recomiendo que piensen bien qué es lo que quieren instalar de acuerdo a sus necesidades y uso de la computadora, porque luego uno se “aloca” y anda instalando paquetes que ni sabemos usar o que nunca vamos a necesitar y esto obviamente alenta nuestra computadora, y trae un desperdicio en memoria, un ejemplo claro de esto es Chromium, la versión OpenSource del navegador de Google, como saben Ubuntu trae por default Firefox, así que si estas cómodo con el, no tiene caso que instales otro navegador, otro caso es GIMP que desde esta nueva versión ya no viene por default en Ubuntu, si nunca lo usaste en versiones anteriores o si no te interesa simple y sencillamente no lo instales, bueno estos son sólo algunos ejemplos con los que nos podemos topar en esta lista.

AÑADIR REPOSITORIOS PPA MAS FACILMENTE

Desde Karmic se incluyó un nuevo comando que nos facilita la tarea de añadir repositorios desde la consola, este es el comando “add-apt-repository”; los repositorios son sitios de Internet desde los que instalamos aplicaciones. Muchas veces ocurrirá que quieres instalar una determinada aplicación y el sistema operativo te mostrara un error de que “no encuentra el paquete”, esto se debe seguramente a que intentas instalar una aplicación y no tienes un repositorio que te permita acceder a ella.

La solución consiste en añadir el repositorio correspondiente, actualizar la lista de repositorios para que Ubuntu sepa asociar aplicaciones-repositorios y ahora sí podrás instalarla.

Puedes gestionar repositorios de muchas formas: con Synaptic, Ubuntu-tweak (que se vera posteriormente), de manera manual, o editando como usuario “root” tu fichero /etc/apt/sources.list y añadiendo las lineas del repositorio correspondiente.

Estas eran las formas “habituales” de añadir un nuevo repositorio, pero ahora con el comando “add-apt-repository” todo se hace mas fácil.

La sintaxis es:

$ sudo add-apt-repository [reporitorio PPA que se quiere añadir]

Con esto Ubuntu, automáticamente se encarga de añadir ese repositorio a nuestro fichero /etc/apt/sources.list y de importar la clave del repositorio.

ACCESO A LA CONSOLA DEL SISTEMA

(Para los recién llegados) La mayoria de los comandos que veremos en este popurrí, los tendrás que escribir desde la línea de consola, que en Ubuntu se llama Terminal y para aquellos que vienen de Windows, sería el equivalente al símbolo del sistema o el MS-DOS.

Es verdad, hay métodos para instalar aplicaciones de manera gráfica, pero una vez que te vas acostumbrando al uso de la Terminal (y una vez que navegas por la blogósfera y encuentras que casi todas las soluciones siguen este método), verás que la terminal es mucho más sencilla, amigable y sobre todo, rápida.

Para acceder a la consola ejecutas desde el menu Aplicaciones > Accesorios > Terminal

SER USUARIO ROOT

La mayoría de estos comandos tendras que ejecutarlos con un usuario que tenga los suficientes privilegios, esto en los entornos Linux, es conocido como “Super usuario” o “Usuario Root”, para “convertirte en usuario root sólo tienes que ejecutar desde la terminal:

$ sudo -s

Te pedira el password (el cuál por cierto, parecerá que no se escribe), de esta manera el nombre de tu usuario en la terminal pasará de ser algo como root@nombre_de_tu_maquina.

Una vez que eres root, literalmente eres Dios en ese sistema así que puedes hacer de todo (ten cuidado pues “jugar” en este modo podría hacer que perdieras información valiosa o que volvieras inestable el sistema, vamos pues, ser usuario root te da tantos privilegios que literalmente con un comando puedes borrar el SO completito), el usuario root es el usuario que tienes mas privilegios en la máquina, y con él puedes acceder a cualquier arbol de ficheros, crear nuevos usuarios, borrar archivos protegidos, etc…

Ahora bien, hay una forma más “segura” de ser usuario root, esto se logra anteponiendo a cualquier orden o comando la palabra “sudo” que básicamente significa “Super User Do” esto lo que hace es concederte privilegios de superusuario de manera temporal (obviamente previa introducción de la contraseña) por lo que si sólo buscas instalar una aplicación, en lugar de estar logueado (así se dice cuando entras a la terminal) todo el tiempo como root, puedes simplemente “invocar” al superusuario por ese comando u acción.

Un ejemplo básico de esto sería actualizar nuestra lista de repositorios, en lugar de escribir sudo -s y después apt-get update, sólo tendríamos que escribir:

$ sudo apt-get update

Si quieren saber un poco más de la terminal y los repositorios pueden ver esta entrada la cual preparé hace mucho tiempo pero lo hice justamente pensando en mí como un usuario recién llegado a Ubuntu (proveniente de Windows Vista) con nulos o muy pocos conocimiento de computación (recuerden que soy politólogo), también lo hice porque muchas veces nosotros como bloggers olvidamos ciertas cosas que ahora me pueden parecer muy sencillas pero que en su momento nos costaron bastante trabajo de encontrar, de hecho el origen de este blog era justamente hacer tutoriales de instalación de diversos programas de manera que cualquier usuario pudiera aplicarlos (el que haya desviado mucho o poco el camino ha dependido de mis experiencias con el software libre jeje).

Bien, aclaradas estas cuestiones, empezamos…

INSTALAR SOFTWARE MÁS RÁPIDAMENTE

Suele ocurrir (y especialmente) cuando sale una nueva versión de Ubuntu, que los repositorios desde los cuales solemos descargar software están muy saturados, si queremos descargar e instalar el software mas rápidamente, tendremos que modificar la lista de repositorios. Existe una opción de Synaptic, que nos permite seleccionar un servidor mas cercano a nuestra región.

Para cambiar este servidor a uno mas cercano vamos a Sistema>Administración> Orígenes de software y en la pestaña “Software de Ubuntu”, seleccionamos “descargar desde:” indicando la región mas cercana a la nuestra:

CAMBIAR EL ASPECTO

Si bien es cierto que en anteriores versiones de la distribución, el aspecto marrón no era del agrado de mucha gente, ahora en esta versión cuidaron mucho el diseño o más bien debería decir el rediseño, de entrada se abandonó el color marrón para adoptar una mezcla entre fanta de naranja y una berenjena (que a pesar de cómo suena, me gustó mucho), además del cambio de color “institucional” hubo otros cambios más “radicales” que han hecho que más de uno suelte una rabieta, desde luego que estoy hablando de la posición de los botones (ahora del lado izquierdo) y que lanzaron una polémica tal que hasta Mark Shuttlesworth (ex CEO de Canonical) saliera a defender la posición, argumentando que “Ubuntu no es una democracia” jajaja, yo en lo personal no le tomé mucha importancia al asunto de los botones, en lo personal siento que hubo cambios que sí afectaron a la distro sobre todo en términos de la filosofía del software libre (como que la plataforma de Ubuntu ONE y obviamente de Ubuntu ONE Music Store sean cerradas; o que el nuevo motor predeterminado de Firefox tenga como corazón a BING, el buscador de Microsoft), pero bueno la comunidad creyó en su momento que la posición de los botones era más importante y quien soy yo para cuestionarlos jeje. Además me estoy saliendo del tema, para cambiar un tema en Lucid sólo ve a Sistema>Preferencias>Apariencia o dando click derecho sobre cualquier espacio libre del escritorio y seleccionando en la opción “cambiar el fondo de escritorio” y de ahí pasándonos a la pestaña “tema”.

Aparecerá una ventana con los temas que tienes disponibles, haz click sobre alguno de ellos y de manera automática cambiará el aspecto de las ventanas y los controles.

Si aun así, no resulta de tu agrado ninguno de los temas incluídos, instalar un tema (ya sea decorador o un pack de iconos) por lo general consiste en descargar el un archivo .tar.gz (que contiene el tema) y arrastrarlo sobre la ventana anterior.

Si un tema no se te instala correctamente (se resiste) viene bien saber que estos temas se descomprimen en tu directorio Home en la carpeta .themes (la cual aparece tecleando Ctrl+h en tu directorio Home) o en /usr/share/themes, así que puedes probar a llevarte el fichero .tar.gz a esos directorios y descomprimir el tema directamente.

Puedes encontrar miles de temas, así como decoradores de ventanas, packs de íconos, wallpapers y muchas cosas más, en sitios como KDE-LookGnome-Look.

CAMBIAR LA IMAGEN DE FONDO

Para cambiar la imagen de fondo del escritorio (Wallpaper), haz click derecho sobre un área vacía del escritorio y del menú emergente que aparece, selecciona “Cambiar el fondo de escritorio“, aparece una nueva ventana donde puedes seleccionar cualquier imagen que tengas almacenada en tu disco duro.

ACTIVAR LOS REPOSITORIOS UNIVERSE, RESTRICTED Y MULTIVERSE

Como he comentado anteriormente, los repositorios son servidores de internet desde donde descargamos los paquetes que queremos instalar en nuestro Sistema.

Hay determinado Software que por defecto no podemos instalar porque no tenemos activados los repositorios correspondientes. Si te interesa y quieres instalar este software, también desde la pantalla de “Orígenes del Software” (Sistema> Administración>Orígenes de Software) puedes activar estos repositorios:

  • restricted: Contiene controladores privativos para dispositivos.
  • universe: Contiene software libre mantenido por la comunidad.
  • multiverse: Contiene software restringido por copyright y cuestiones legales

Tras activarlos tendrás accesibles nuevos paquetes para instalar.

ACTIVAR CONTROLADORES PRIVATIVOS DE HARDWARE

Es posible que tu entorno gráfico no se muestre correctamente o que no estés utilizando los drivers más eficientes para tu tarjeta gráfica, esto lo puedes comprobar desde Sistema>Administración>Controladores de Hardware.

Desde esta ventana aparecerán los controladores disponibles que puedes utilizar y si se encuentran activados o no, si los usas, seguramente obtendrás una mejora de rendimiento pero estarás usando software privativo.

INSTALAR EL SOFTWARE BÁSICO DE COMPILACIÓN

Linux es “libertad”, Así que muchas veces no te encuentras un ejecutable para instalar, pero sí el código fuente de esa aplicación, ventajas de esto, que puedes agarrar tú mismo el código fuente y mejorarlo (si dispones de los conocimientos necesarios) o adaptar una aplicación a lo que necesites (si la licencia de uso lo permite); desventajas, que muchas veces no tendremos el binario ejecutable de la aplicación y necesitaremos compilar nosotros mismos ese código fuente (lo que es una fuente de problemas para alguien que esta empezando).

De todas formas si queremos compilar algún paquete del que solo tenemos el código fuente, tendremos que instalar los paquetes básicos de compilación y esto lo instalamos escribiendo en una terminal lo siguiente:

$ sudo aptitude install build-essential

A partir de entonces ya podemos usar los comandos como “gcc” o “make”, también podemos instalar las librerías de desarrollo del kernel que tengamos instalado y que son necesarias para la compilación de determinados paquetes:

$ sudo aptitude install linux-headers-`uname -r`

INSTALAR LOS EXTRA RESTRICTIVOS

Hay ciertos paquetes que no vienen por defecto en Ubuntu por cuestiones legales, esto se debe a un tema de licencias, por ejemplo cuando se instala ubuntu, por defecto no instala todo ese software comercial que no ha liberado el código fuente.

Ejemplos de este software puede ser el plugin de flash, o los códecs para poder reproducir algunos formatos de audio y vídeo, etc., sin embargo, existe un metapaquete (un paquete que agrupa e instala muchos paquetes) llamado ubuntu-restricted-extras que nos permite instalar todo este software que no es instalado por defecto y que tanto necesitamos para poder ver ese vídeo o reproducir ese mp3 que se resiste.

Sólo hace falta escribir en una terminal:

$ sudo aptitude install ubuntu-restricted-extras

En este metapaquete encontraremos el plugin de flash, algunas fuentes de texto de Microsoft, la última versión de Java, y varios códecs (entre ellos el soporte de MP3 y DivX).

INSTALAR UBUNTU-TWEAK

Ubuntu-Tweak es una aplicación muy útil, sobre todo para usuarios nuevos o para aquellos que no quieren complicarse de más la vida, ya que es un programa que agrupa un buen número de acciones administrativas que van desde agregar o quitar repositorios con sólo “palomear” el repositorio, hasta cosas más avanzadas o con procedimientos más complicados como cambiar el logo de la distribución, activar los efectos avanzados de escritorio, administrar las plantillas de los documentos y un largo etcétera, todo esto desde una interfaz gráfica muy amigable.

Para instalarlo:

Añadimos la clave PPA:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com FE85409EEAB40ECCB65740816AF0E1940624A220

Añadimos la siguiente línea a nuestro fichero /etc/apt/sources.list (nos vamos al menú de Orígenes del Software y en la pestaña “Otro Software” picamos el botón que dice añadir y ahí pegamos la línea. La otra opción (más complicada, es que tienes que abrir este fichero como “root” con algún editor de texto, como puede ser gedit, es decir, escribimos desde una terminal: sudo gedit /etc/apt/sources.list y agregamos la siguiente línea):

deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu lucid main

Actualizamos la lista y después instalamos Ubuntu Tweak con:

sudo apt-get update
sudo apt-get install ubuntu-tweak

INSTALAR SOPORTE DE DVD Y TODOS LOS AUDIO/VIDEO CÓDECS EN UBUNTU (MEDIBUNTU)

Nota: Cuidado, porque si usamos Ubuntu-tweak para instalar algunos de estos paquetes, ya estaremos usando los repositorios de Ubuntu-tweak, y no los de Medibuntu (tenlo en cuenta).

Medibuntu es un repositorio donde podemos encontrar algunas aplicaciones y códecs que no son instalados por defecto en Lucid.

Añadimos el repositorio de MEDIBUNTU, escribimos en una terminal lo siguiente:

sudo wget http://www.medibuntu.org/sources.list.d/lucid.list --output-document=/etc/apt/sources.list.d/medibuntu.list

Importamos la clave GPG:

sudo aptitude update && sudo aptitude install medibuntu-keyring && sudo aptitude update

Ahora ya podemos instalar unos cuantos paquetes nuevos:

Para la reproducción de DVD ejecutamos:

sudo apt-get install libdvdcss2
sudo apt-get install libdvdread4

Para instalar Windows codecs, Real Networks, Quick Time y otros:

En Ubuntu 10.04 32 bits ejecutamos:

sudo apt-get install w32codecs

En Ubuntu 10.04 64 bits ejecutamos:

sudo apt-get install w64codecs

Instalar otros códecs adicionales:

sudo aptitude install non-free-codecs

SOPORTE DE FORMATOS COMPRIMIDOS

Si queremos poder comprimir o descomprimir de los formatos mas populares (rar, zip, gz, ace, etc):

sudo aptitude install rar p7zip-full unace unzip file-roller

De hecho este descompresor es mucho mejor que otros que circulan en los circuitos de software cerrado como WinRar o WinZip.

INSTALAR COMPIZ Y ACTIVAR EFECTOS 3D

Sin duda este es de los paquetes más inútiles pero más “apantalladores” que hay, digo inútil porque todo usuario que lleve algún tiempo con Ubuntu sabe que el famosísismo “Cubo” es de las primeras cosas que presumimos cuando le enseñamos nuestra computadora a otra persona, en verdad que es muy estético, sin embargo (y tampoco me dejarán mentir los ubunteros más experimentados) con el paso del tiempo incluso olvidas que lo tienes instalado y sólo lo recuerdas vagamente por los efectos que le pones a tus ventanas (como que cuando las muevas, se hagan como gelatina o que cuando las minimizas parezca que salen como un genio de una lámpara mágica, pero bueno el punto es que si eres farol (como yo jeje) y te gusta presumir tu computadora para que más personas digan “yo quiero eso en mi compu”, Compiz es de esos paquetes imprescindibles.

Para instalar Compiz (y poder disponer de efectos 3D en nuestro escritorio) tendremos que ejecutar una serie de comandos.

Primero agregamos el repositorio:

sudo add-apt-repository ppa:compiz

Actualizamos la lista de repositorios:

sudo apt-get update

E instalamos:

sudo aptitude install simple-ccsm compizconfig-settings-manager emerald

Ahora podremos activar algunos efectos desde Sistemas>Preferencias>Apariencia>Efectos Visuales

Si quieres saber cómo “sacar” el famoso cubo, da click en este tutorial que preparé hace tiempo: “Tutorial: Sacar el Cubo y otros efectos de Escritorio con Compiz”

Si Emerald (el decorador de ventanas) no carga correctamente, ejecuta el siguiente comando:

/usr/bin/emerald --replace

COMPOSICION BASICA SIN COMPIZ

Si quieres algunos efectos de transparencias y sombras en Metacity (el gestor de ventanas Gnome) y no usas o tu tarjeta no soporta Compiz, puedes activar estos efectos simples ejecutando desde consola:

gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true

INSTALAR CHROMIUM O GOOGLE CHROME

Fue hace poco cuando se liberó la primera versión oficial para Linux de Google Chrome y antes teníamos que agregar repositorio y una que otra cosa para instalar este excelente navegador, sin embargo ahora todo es más fácil y desde la página de Google lo puedes descargar, está en formato .deb por lo que una vez descargado sólo tendrás que dar doble click en el archivo y después de dar unos cuantos clicks lo tendrás instalado, aprovecho este pequeño espacio para hablar de los archivos .deb, este tipo de archivos provienen del “padre” de Ubuntu (Debian) y básicamente podría resumirlos como los .exe de Ubuntu, es decir son archivos que ya vienen con todo incluido para que con unos cuantos clicks todo se instale.

Actualmente la versión de Google Chrome para Linux está en estado Beta, pero es muy estable, de hecho es mi navegador favorito y la verdad es que ya casi no me acuerdo el “zorrito de fuego”.

Además de Chrome, existe un desarrollo paralelo y que además es completamente open Source llamado Chromium, también para instalarlo se tenían que hacer algunos movimientos en la terminal pero ahora ya está en los repositorios oficiales de Ubuntu y con ir al Centro de Software de Ubuntu (Aplicaciones>Centro de Software), escribimos en el espacio de búsqueda “Chromium”, le picamos en “instalar” y listo, después de unos segundos lo tendremos instalado.

INSTALAR FIREFOX DIARIO

Claro que siempre hay quienes gustan de Firefox (que por cierto viene por default en Ubuntu), para ellos les ofrezco la opción de agregar el repositorio, para que el navegador del “zorrito de fuego” esté constantemente actualizado, para ello escribimos en una terminal:

sudo add-apt-repository ppa:mozillateam/firefox-stable

Con esto tendremos las últimas versiones de Firefox, hay que recordar que cuando sale una nueva versión de Ubuntu, procurán traer consigo las versiones más actuales de los paquetes, sin embargo no está demás agregar el repositorio para futuras versiones.

INTEGRAR FIREFOX CON LAS NOTIFICACIONES DE LUCID

Desde Ubuntu 9.04 Jaunty Jackalope, hay un nuevo sistema de notificaciones, si quieres que Firefox esté integrado con él, instalamos la siguiente extension y listo.

INSTALAR SOPORTE PARA APLICACIONES JAVA

Si no tienes el JRE (Java Runtime Environment) instalado en tu máquina y necesitas ejecutar alguna aplicación basada en Java necesitaras instalarlo previamente o no podrás lanzar esas aplicaciones.

Puedes instalar JRE con:

sudo aptitude install sun-java6-fonts sun-java6-jre sun-java6-plugin

INSTALAR JDOWNLOADER

JDownloader es uno de los mejores gestores (yo digo que el mejor) de descargas que soporta la descarga directa desde los sitios mas populares (p.ej Rapidshare y MegaUpload).

Para instalarlo sólo hace falta ir a la página de Jdownloader y bajar el siguiente scrip llamado “jd.sh”; ahora nos vamos a una terminal y navegamos a la carpeta de Descargas (o aquella que hayas seleccionado para tal fin), esto lo hacemos con:

cd Descargas (o la ruta del directorio donde descargas tu cosas)

Una vez ahí hacemos que el archivo sea ejecutable con:

chmod +x jd.sh (donde jd.sh es el nombre del archivo que descargaste, esto lo digo en caso de que cambie)

Y por último escribimos en una terminal:

./jd.sh

Después de unos minutos (en lo que se actualiza la aplicación) tendremos en nuestro equipo Jdownloader, así que a bajar se ha dicho jajaja

Para volver a ejecutar Jdownloader tienes que repetir el último comando (ubicándote primero en la carpeta en la que está el archivo jd.sh), con esto puedes crear tu propio lanzador para evitar hacer eso en cada ocasión que lo necesites.

INSTALAR SHUTTER

Para realizar capturas de pantalla es la mejor herramienta que hay (incluso mejor que la que trae por default Ubuntu). Permite hacer capturas de la pantalla completa, de web, de selecciones o ventanas.

Para instalarla:

sudo aptitude install shutter

INSTALAR DOCKY

Docky es un buen Dock para el sistema, una aplicación que nos permite lanzar rápidamente tareas o gestionar las mismas a través de su vista en modo de iconos (Junto con Avant Window Navigator, de los mejores en su ramo).

Para Instalar Docky:

sudo add-apt-repository ppa:ricotz/testing
sudo apt-get update
sudo apt-get install docky

INSTALAR AVANT-WINDOW-NAVIGATOR

Instalarlo en Ubuntu 10.04 Lucid es muy sencillo, yo recomiendo que si ya instalaron Ubuntu Tweak, lo instalen desde ahí (sólo tienen que seleccionarlo), pero para aquellos que no instalaron Tweak:

sudo add-apt-repository ppa:awn-testing
sudo apt-get update && sudo apt-get install avant-window-navigator-trunk

Después para iniciar AWN nos vamos a Aplicaciones>Accesorios>Avant Window Navigator.

INSTALAR SCREENLETS

Los screenlets son pequeñas miniaplicaciones de escritorio (similar a Google Gadgets o a los Gadgets de la barra lateral de Windows, por cierto sigue existiendo?) que proporcionan diversas funcionalidades (relojes, medidores de consumo de la bateria, estado del clima, etc). Puedes instalarlos con:

sudo aptitude install screenlets

INSTALAR WINE

Si tienes alguna aplicación para Windows que uses y no esta disponible para Linux, es posible (POSIBLE, aunque wine cada día es mejor y llega incluso a ser afectado por los virus de la misma manera que lo haría Windows, no todos los programas “jalan” bien) que puedas ejecutarla con wine (por cierto wine significa Wine Is Not an Emulator).

Para instalar wine:

$ apt-get install wine

Después ejecutamos:

$ winecfg

Para configurar Wine.

Si además queremos una apariencia gráfica de wine que este mas de acorde con Ubuntu hacemos:

$ gedit ~/.wine/user.reg

Y remplazamos la seccion [Control Panel\\Colors] con:

[Control Panel\\Colors] 1176981676
“ActiveBorder”=”239 235 231″
“ActiveTitle”=”203 133 61″
“AppWorkSpace”=”198 198 191″
“Background”=”93 77 52″
“ButtonAlternativeFace”=”200 0 0″
“ButtonDkShadow”=”85 85 82″
“ButtonFace”=”239 235 231″
“ButtonHilight”=”255 255 255″
“ButtonLight”=”255 255 255″
“ButtonShadow”=”198 198 191″
“ButtonText”=”0 0 0″
“GradientActiveTitle”=”239 235 231″
“GradientInactiveTitle”=”239 235 231″
“GrayText”=”198 198 191″
“Hilight”=”246 200 129″
“HilightText”=”0 0 0″
“InactiveBorder”=”239 235 231″
“InactiveTitle”=”239 235 231″
“InactiveTitleText”=”255 255 255″
“InfoText”=”0 0 0″
“InfoWindow”=”255 255 166″
“Menu”=”239 235 231″
“MenuBar”=”239 235 231″
“MenuHilight”=”246 200 129″
“MenuText”=”0 0 0″
“Scrollbar”=”239 235 231″
“TitleText”=”255 255 255″
“Window”=”255 255 255″
“WindowFrame”=”0 0 0″
“WindowText”=”0 0 0″

INSTALAR MENSAJERIA INSTANTANEA

En esta versión de ubuntu se dio principal atención a la integración con las redes sociales con programas como Gwibber y Empathy, sin embargo en el mundo del software libre existen múltiples opciones a estos programas.

En el caso de los clientes de mensajería instantánea (y si no te gustó Empathy) puedes instalar:

AMSN

sudo apt-get install amsn

Emesene:

sudo apt-get install emesene

Skype (sí, es de las pocas aplicaciones que tiene versión oficial para Linux):

sudo aptitude skype

O si lo prefieres puedes usar Pidgin (el mejor desde mi punto de vista):

Para instalar la ultima versión:

sudo add-apt-repository ppa:pidgin-developers

Después actualizamos e instalamos:

sudo apt-get update
sudo aptitude install pidgin

DESCARGA P2P

Emule, es uno de los programas P2P mas populares para descargar por internet. La versión en Linux se instala con:

sudo aptitude install amule

INSTALAR REPRODUCTORES DE VIDEO: VLC

Aunque Totem (el reproductor de vídeos oficial de Ubuntu) es muy bueno, hay quienes prefieren a este clásico de la reproducción, en parte porque es muy minimalista pero sobre todo porque va a ser difícil que encuentres algo que no pueda reproducir.

Lo puedes instalar con:

sudo apt-get install vlc

Hay un repositorio PPA tambien para VLC:

sudo add-apt-repository ppa:c-korn

Otra alternativa a VLC para visualizar videos es SMPlayer:

sudo apt-get install smplayer

LECTOR DE COMICS

¿Te gusta leer cómics o novelas gráficas?, entonces, nada como comix:

sudo aptitude install comix

TRADUCIR OPENOFFICE AL CASTELLANO

OpenOffice 3.2 ya viene por defecto en Lucid y si escogiste bien tus idiomas desde la instalación de Ubuntu, no deberías tener problemas y OpenOffice debería estar en español (incluso con la variante de tu país), pero en caso de que no, ve a Synaptic (Sistema>Administración>Gestor de Paquetes Synaptic) ahí teclea Ctrl+f para que aparezca el cuadro de búsqueda, ahí escribe “OpenOffice”, ahí selecciona todos los paquetes de tu idioma (la clave para español obviamente es ES y creo que viene hasta la variante por lo que si eres de México sería algo así como ES-MX, como referencia está casi siempre junto a los paquetes que trae instalado por default ubuntu en todo el mundo, es decir los paquetes de inglés o sea (EN)) son aproximadamente 5 o 6 paquetes los que tienes que marcar, una vez marcados da click en el botón “aplicar” acto seguido se te pedirá tu permiso para realizar esas acciones y lo instalarás, ya con eso tendrás OpenOffice en tu idioma.


SI TIENES WEBCAM

Instala Cheese:

sudo apt-get install cheese

PARA CREAR IMAGENES AUTOARRANCABLES DESDE USB

Si tienes una imagen .iso de tu sistema operativo y quieres crear un Live-USB para llevártelo a cualquier sitio (de hecho Ubuntu ya trae por default un programa propio para hacer estos “menesteres” sin embargo en mi experiencia personal falla constantemente o si ya usaste alguna vez una usb para hacer un Live-USB y luego la formateaste o quieres hacer otro Live-USB de otra distro, ya no te deja tan fácilmente por lo que recomiendo muchísimo Unebotin, ya que es sencillo, muy gráfico y hasta te da la opción de que si aún no tienes la imágen .iso de tu distro, la puede bajar por tí:

sudo apt-get install unetbootin

INSTALAR EDITOR DE PARTICIONES

Si necesitas redimensionar una partición o borrar/crear nuevas particiones en el disco duro:

sudo apt-get install gparted

Hasta el momento aquí dejo este megapost que es cortesía de Ubuntu Life y su servilleta (con algunos cambios, actualizaciones y otras cosas), cabe mencionar que quité muchas opciones de instalación del post original, por varias razones:

  1. Sé lo que es ser un usuario “novato” o recién llegado y aunque las necesidades de cada uno son diferentes consideré cuales eran las aplicaciones que realmente un usuario nuevo utiliza, por lo que consideré que había ciertas aplicaciones que no tendrían uso en un usuario normal.
  2. También dejé sólo las que yo instalo como parte de mi “ritual” después de instalar Ubuntu, con esto no tengo ningún problema, veo vídeos, escucho música, navego por internet, escribo ensayos, en resumen, todo lo que un usuario normal haría.
  3. Por último también quite algunas aplicaciones o porque no tengo ni idea de como es la sintaxis para su repositorio en Lucid Lynx, o porque ya vienen incluidos en esta versión de Ubuntu (un ejemplo es el editor Pitivi) o porque simple y sencillamente nunca las he usado con lo que engañaría a los lectores dándoles información que no puedo corroborar.

Espero que aprecien el esfuerzo que realicé (en verdad me eché una tarde completa) porque tuve que revisar no sólo sintaxis de los comandos, imágenes adecuadas y toda la chorrada de cosas que hago para escribir un post, sino que también tuve que corregir muchas faltas de ortografía que si bien entiendo que no a todo el mundo le interesa, para mí sí es importante. (aunque si ven una o dos, no se vayan a poner como policías contra mí, como me pasó alguna vez en un post en el que quien me comentaba, decía que mi lenguaje era limitado por usar la palabra accesar en lugar de introducir o algo más jaja).

Obviamente por el carácter de este post, está sujeto a revisiones y reediciones (de hecho pienso publicarlo el día del lanzamiento de Lucid) por lo que no duden que si en Ubuntu Life o en otro blog veo aplicaciones interesantes para agregar a este tutorial, lo haga.

Saludos.

comentarios
  1. […] Instalar Lucid (BETA) y luego qué? « Libertad Zero […]

  2. […] Instalar Lucid (BETA) y luego qué? « Libertad Zero […]

  3. José Luis dice:

    Interesantísimo.Me lo guardo para cuando lancen la nueva versión.

  4. akheron dice:

    Buen tutto de algunas cuantas aplicaciones para dummies, creo que la unica que me llamo la atencin es jdownloader, la voy a probar a ver que tal rifa.

    Por cierto, yo sin mas ni mas ¡¡Fedora rulezz!!.

    • chocochuck5 dice:

      En efecto, este tuto no está hecho para gente más experimentada sino como una introducción a quienes vienen llegando, sin embargo qué bueno que te interesó jdownloader, yo te puedo decir que es el mejor gestor de descargas que conozco (bueno sólo he probado además de jdownloader Tucan), es sencillo de usar y te ahorra un montón de tiempo.
      De lo de fedora no te creas, alguna vez lo probé (con Moblin 2.1) pero no me gustó porque no entendí muy bien lo de los comandos, pero eso no significa que no le daría una segunda oportunidad, aunque claro me gustaría que alguien que sí sepa me enseñara jeje.

      Saludos.

  5. Carlos dice:

    Hola, de nuevo yo. Me gusta mucho tu blog y lo leo seguido. Pero, como en una ocasión anterior, no puedo dejar de comentar sobre algunas faltas en el lenguaje. Y atención, son faltas, no son errores, y el hecho de que cometamos (me incluyo) faltas es parte del aprendizaje; éste último, es un proceso continuo que nunca termina, así que siempre estamos aprendiendo algo nuevo. Pues bien, he aquí mis tres sugerencias:

    Primera. La palabra “súper” lleva acento.

    Segunda. “Alentar” no quiere decir “volver(se) lento”; para ello existen ya dos verbos: ralentizar y lentificar. Alentar es como motivar, estimular, animar, etc.

    Tercera y la más importante: ¿qué es “por default”? ¿qué siginifica la palabra “default”? Disculpa mucho que te corrija esto, pero no me gusta porque jamás he escuchado a la gente decir la palabra “default”. Esta palabra del inglés, que se ve en los parámetros de instalación de programas, corresponde en español a la expresión “por defecto”. Así que, por ejemplo, Ubuntu trae un fondo de escritorio por defecto.

    Y ahora me acuerdo de una cuarte: “Wallpaper”. Pues bien, la acabo de escribir: “fondo de escritorio”.

    Oye, Chocochuk5, espero que no te enfades conmigo. Me gusta mucho que defiendas la causa del software libre y por eso soy uno de tus seguidores. Pero comprenderás que para que tus articulos sean perfectos (porque de por sí ya son excelentes en contenido y tu estilo es muy agradable), necesitas mejorar unos pequeños detalles de la forma. Además, como politólogo, tienes que prestarle mucha atención al manejo del lenguaje.

    Bueno, eso es todo por el momento. Gracias por tu atención, gracias por tus artículos (la quinta: “post”; la sexta: “blogger”, para mí eres un bloguero) y por compartir con el mundo y tus lectores tan valiosa información.

    Cordialmente,

    Carlos.

    • chocochuck5 dice:

      Hola de nuevo tocayo entiendo a la perfección la razón de tus comentarios, es verdad algunas veces “switcheo” jaja no no es cierto, intercambio palabras del inglés al español y viceversa, pero hay veces que lo hago por comodidad, por ejemplo siempre me ha molestado la palabra fondo de escritorio, prefiero wallpaper por comodidad pero si existe una traducción literal no es fondo de escritorio, más bien sería papel tapiz, lo mismo aplica en los casos de post=entrada, blogger=bloguero, pero tomándo en cuenta tus comentarios, trataré de usar más las palabras en español que en inglés.
      Respecto a lo de “por default” creo que “por defecto” aparte de ser incómodo es raro, un defecto es algo (por lo menos para mí) que está mal y que puede o no corregirse, el decir, “por defecto” se me hace como decir “por error” o “porque no hay de otra” y otra vez vuelvo al punto que una traducción más literal podría ser predeterminado.
      En cuanto a los acentos creo que cuido mucho la ortografía en ese aspecto pero no puedes negar que a cualquiera se le van uno o más acentos, pero también procuraré escribir con más cuidado.
      Por último, repito lo que te dije la vez pasada, no está mal mezclar términos de un idioma u otro, en la actualidad existen pocos o ninguna lengua “pura” y si así fuera, ¿cómo sería?, la historia de la evolución del lenguaje se compone de mezclas de todo tipo, así como aguacate y otras palabras de origen mesoamericano pasaron a engrosar nuestro idioma, no veo nada de malo en usa palabras del inglés en el nuestro (o de cualquier otro idioma); además también tienes que reconocer que la gran mayoría de las tecnologías en la actualidad surgen o se desarrollan primero en ingleś y luego en otros idiomas, esto genera incluso dentro del inglés neologismos como podría ser twittear Twitting), bloguear (Blogging), etc.
      Insisto, creo que no tiene nada de malo pero como dije intentaré usar estos términos lo menos posible.

      Saludos.

  6. “…el nuevo motor predeterminado de Firefox tenga como corazón a BING, el buscador de Microsoft…” Que extraño, Tu propio artículo al que haces referencia es correcto pero en este post mencionas que Ubuntu cambia su buscador por defecto de Google a Bing cuando en realidad el cambio es de Google a Yahoo.

    Sobre la instalación del JRE, ¿porque no mejor recomendar OpenJDK 6 la cual certificaron compatible desde Ubuntu 9.04 con la plataforma Java SE 6 [1]? “sudo aptitude install openjdk-6-jre icedtea6-plugin” y en caso de requerir el JDK: “sudo aptitude install openjdk-6-jdk”. Si hay alternativas libres y compatibles para una funcionalidad, ¿porque insistir en usar las propietarias?

    Para JDownloader te recomiendo crear un acceso en el menú para no tener que estar ejecutando el comando cada vez, para ello debes ir a: “Sistema – Preferencias – Menú Principal”, y dentro de “Aplicaciones – Internet” seleccionar la opción “Elemento Nuevo”, e ingresas los siguientes valores (adaptando las rutas en el comando y el ícono a donde hayas descomprimido JDownloader:
    Tipo: Aplicación
    Nombre: JDownloader
    Comando: /usr/bin/java -jar /home/usuario/Apps/JDownloader/JDownloader.jar
    Comentario: Download manager for one-click hosting sites
    Ícono: /home/usuario/Apps/JDownloader/jd/img/logo/icon.ico
    O en el comando en vez de usar el jar usa el script (no scrip) que mencionas: “sh /ruta/a/jd.sh”

    “Skype (sí, es de las pocas aplicaciones que tiene versión oficial para Linux):”
    “sudo aptitude skype” Debe ser: “sudo aptitude install skype”, pero olvidaste mencionar de que repositorio lo instalas, ya que hasta donde sé, Skype no esta disponible en ningún repositorio de Ubuntu y debes descargar el DEB de acuerdo a Tu arquitectura (32 o 64 bits) desde la página de Skype [2]. Más información sobre Skype en Ubuntu acá [3].

    “$ apt-get install wine” debe ser: “$ sudo apt-get install wine” o “# apt-get install wine”.

    Felicidades por el post, se agradece el tiempo que has invertido, y estas sugerencias no tienen el afán de criticar o atacar, sino considerando que planeas reeditarlo para el lanzamiento, que sea de la mejor manera y con la menor cantidad de errores posibles para no ocasionar dolores de cabeza en los usuarios que usarán Ubuntu por primera vez 🙂

    Saludos y buen día

    P.D.1. Te recomiendo no mezclar “apt-get” y “aptitude”, es decir, no instales una cosa con “sudo apt-get install paquete1” y otra con “sudo aptitude install paquete2”.

    P.D.2. No necesariamente todo lo que he mencionado funcionará, ya que no uso Ubuntu sino Debian, así que te agradeceré lo revises cuidadosamente.

    P.D.3. Podrías considerar difundir este artículo en el FLISOL ;), ¿como va el grupo de usuarios con el que estas trabajando en Tu facultad?

    [1] https://lists.ubuntu.com/archives/ubuntu-devel-announce/2009-July/000587.html
    [2] http://www.skype.com/download/skype/linux/choose/
    [3] https://help.ubuntu.com/community/Skype

    • chocochuck5 dice:

      Muchas gracias por todos los comentarios, y no, no creas que me lo tomo a mal, al contrario, si encuentran errores o formas más fáciles de hacer las cosas adelante.
      respecto al grupo de usuarios de la facultad ahi va creciendo poco a poco, cada vez son más las personas que por lo menos conocen qué es el software libre sin embargo aún no pasamos de ser como 20 0 30 personas aunque cada una lo difunde en diferentes formas por lo que estoy muy contento.
      En lo de FLISOL, claro que estoy dispuesto a difundirlo pero no sé de qué manera, si tu me puedes ayudar con eso te lo agradecería.

      Saludos.

  7. leon dice:

    demasiado largo para ponerlo en http://planetalinux.org/mx/

    te recomiendo usar el tag de wordpress

  8. folken2784 dice:

    bueno soy usuario novato de gnu/linux y tengo un problema con un repositorio el de commpiz me dice lo siguiente
    W: Imposible obtener http://ppa.launchpad.net/c-korn/ppa/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

    W: Imposible obtener http://ppa.launchpad.net/compiz/ppa/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

    E: Algunos archivos de índice no se han podido descargar, se han ignorado,
    o se ha utilizado unos antiguos en su lugar.

    ammm una cosa mas pedo poner esta info en taringa

    • chocochuck5 dice:

      Primero que nada bienvenido a esto del Software Libre, segundo, en ese post hablo sobre la versión Beta, es decir que aún está en fase de pruebas, la verdad no recomiendo que instales esta versión, para usuarios nuevos, siempre será recomendable usar las versiones finales que ya circulan (actualmente la 9.10 Karmic Koala) aunque siendo honesto en este momento nos encontramos en una especie de limbo, pues estamos a sólo unos días del lanzamiento de la nueva versión de ubuntu.
      Lo primero que quiero que cheques es qué versión de Ubuntu instalaste en tu computadora si la 9.10 o la 10.04 beta, la forma más fácil de saberlo es en el menú principal en Sistema>Acerca de Ubuntu, ahí lo primero que dice es la versión que usas, si dice que estas usando la versión 9.10 entonces ya está resuelto el problema, el repositorio que estas usando no corresponde a la versión de Ubuntu que estás usando.
      Si por el contrario estas usando la versión 10.04 entonces quizá el problema venga de la sintaxis del comando, es decir, puede ser que hay un error en la manera en la que está escrito (puede ser desde un espacio hasta una letra en minúsculas o en mayúsculas o qué se yo), también esto se puede deber a que como te expliqué antes, esa versión de ubuntu (la 10.04) está en fase de pruebas, por lo que igual y los desarrolladores quitaron temporalmente ese repositorio o combiaron su dirección, lo cual explicaría porque te aparece el error 404 que creo es que la página que buscas no existe.
      Sinceramente te recomiendo que esperes a que salga la versión final de ubuntu 10.04, la verdad es que compiz, lejos de ser un programa para impresionar personas, fuera de eso y una vez que usas ubuntu de manera regular, no es más que una funcionalidad “bonita” pues no es muy útil que digamos.
      De todos modos si tienes más dudas o no sirvieron ninguna de mis ayudas, no dudes en comentarlo para que yo o alguien más, te podamos ayudar.

      Saludos.

    • chocochuck5 dice:

      Ahhh y lo de Taringa, si te fijas en la parte lateral de mi blog hay una licencia de uso de todos los contenidos de este blog, básicamente está permitido copiar parcial o totalmente el contenido de mi blog, siempre y cuando no lucres con dicho contenido si respetas esto, entonces no tengo ningún problema en que reproduzcas cualquier cosa del blog, parcial o totalmente.

      Saludos.

  9. folken2784 dice:

    hola bueno creo que es error de que no esta disponible el repositorio… ammm y respecto a qe version instale es la 10.04 beta1… ya probe la 9.10 pero tuve algunos problemas con samba y lo deje y regrese a xp…y bueno a pesar de ser na beta esta version funciona bien y arranca mas rapido que la 9.10…
    gracias por contestar…
    y bueno lo pondre en taringa porque alguien puso algo sobre un script para que lo instale todo solo pero ammm prefiero la forma manual…

    • chocochuck5 dice:

      oooooopppppssss ese del scrip también fui yo (a menos que ya esté actulizado), hace tiempo, pero como bien dices, mejor la forma manual.

      Saludos.

  10. Vicmas dice:

    Amigos buenos dias, no se si sea el lugar pero ahi va.

    Despues de tanto esperar pues ayer precisamente ya instale esta version pero
    para mi mala suerte no entra se queda en pantalla negra y de ahi no pasa
    tengo instalada otra version la asturix y esa entra perfectamente , bueno
    modifico el grub asi que tuve que usar un disco para arreglarlo, al entrar
    se ve la version de 10.04lts pero nada mas doy click sobre ella y no pasa de ahi
    ya instale dos veces y hasta la version server y nada no pasa nada, quien me
    puede informar sobre el problema, le comento que anterior a esta final tenia
    la version beta2 y esa funcionaba perfectamente aun y con los detalles de una
    beta pero fucionaba muy bien, al instalar la final ya tuve ese gran problema.

    saludos
    JOSE VICMAS

    • chocochuck5 dice:

      La verdad no sé que pueda estar pasando pero porque si dices que la beta funcionaba muy bien, no instalas nuevamente la beta y ya que esté sólo con el gestor de actualizaciones, se actualizará a la última versión, con eso creo que se resolvería tu problema.

      Saludos.

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s