Instalar OpenOffice 3.2.0 en Ubuntu 9.10 Karmic Koala

Publicado: 27 marzo 2010 en Aplicaciones, Software Libre, Ubuntu
Etiquetas:, , , , , , ,

OpenOffice es sin duda una de las suites ofimáticas más importantes que hay en la actualidad, siempre he defendido (frente al monopolio de Microsoft Office) que OpenOffice cumple con cerca del 90% de las necesidades de los usuarios, habrá quienes digan que no es cierto o quienes digan que tienen otra suite como favorita pero bueno ese no es asunto del post, en este post veremos cómo instalar y/o actualizar a la última versión de OppenOffice (o sea la 3.2.0).

Primero nos vamos a la terminal y ahí escribimos lo siguiente:

sudo add-apt-repository ppa:openoffice-pkgs/ppa

Esto es para agregar el repositorio de OpenOffice a nuestra lista de repositorios, una vez hecho esto, sólo tenemos que actualizar la lista y actualizar los programas respectivamente con:

sudo apt-get update
sudo apt-get upgrade

Ahora en caso de que no lo tuviésemos instalado sólo hay que escribir lo siguiente:

sudo apt-get install openoffice.org

Eso es todo, con eso ya tendrán instalada la última versión de OpenOffice.

Saludos.

Visto en | Ubuntronics

comentarios
  1. Marcelo dice:

    Muy buen Artículo. Me sirvio a la perfección.
    Gracias

    Saludos
    Santiago, Chile

  2. Mokochicho dice:

    Lo voy a probar.
    Me hubiera gustado que dijeras cuales son los cambios de esta nueva versión, pero igual se agradece el aporte. GRACIAS!

    • chocochuck5 dice:

      Lo siento pero andaba ocupado cuando escribí, pero no te preocupes, hay montones de blogs donde puedes encontrar los cambios o en la página de openoffice seguro los encuentras.

      Saludos.

  3. Lucas dice:

    Hey chocochuck, buen post. Yo he tenido mis peripecias para tratar de instalar la versión 3.2 de OpenOffice en mi Karmic Koala, todavía no lo he podido hacer, te cuento lo que hice a ver si podés agregar un poco de luz sobre el asunto:

    – Primero desinstalé el 3.1 que venia con el Ubuntu (tenía algunos bugs muy molestos)
    – Luego di con tu post y pude reinstalarlo con sudo apt-get install openoffice.org
    – Luego le di sudo apt-get update para agregar el repositorio a la lista, hasta ahí todo bien
    – Ahora cuando le di sudo apt-get upgrade para instalarlo, a la mitad del proceso de instalación se me puso rojo el terminal avisando de que había un par de errores. Luego al fijarme si había podido instalarlo no pude abrir el programa, aparece la pantalla inicial del OpenOffice 3.1 y se cierra automáticamente. Este es detalle del upgrade. Si se te ocurre algo por favor avisame, no se como resolverlo, he tenido que trabajar con Windows en la semana para terminar un laburo y ya no quiero saber más nada con esa cosa fea. Gracias!

    lucas@Blue Ray:~$ sudo apt-get upgrade
    sudo: unable to resolve host Blue Ray
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    Los siguientes paquetes se han retenido:
    openoffice.org openoffice.org-base openoffice.org-base-core
    openoffice.org-calc openoffice.org-common openoffice.org-core
    openoffice.org-draw openoffice.org-filter-binfilter openoffice.org-impress
    openoffice.org-math openoffice.org-officebean openoffice.org-style-galaxy
    openoffice.org-writer python-uno
    Se actualizarán los siguientes paquetes:
    openoffice.org-emailmerge openoffice.org-filter-mobiledev
    openoffice.org-java-common openoffice.org-report-builder-bin ttf-opensymbol
    uno-libs3 ure
    7 actualizados, 0 se instalarán, 0 para eliminar y 14 no actualizados.
    Necesito descargar 13,0MB de archivos.
    Se utilizarán 5.562kB de espacio de disco adicional después de esta operación.
    ¿Desea continuar [S/n]? s
    Des:1 http://ppa.launchpad.net karmic/main ure 1.6.0+OOo3.2.0-4ubuntu0ppa1 [2.634kB]
    Des:2 http://ppa.launchpad.net karmic/main uno-libs3 1.6.0+OOo3.2.0-4ubuntu0ppa1 [2.318kB]
    Des:3 http://ppa.launchpad.net karmic/main openoffice.org-emailmerge 1:3.2.0-4ubuntu0ppa1 [10,0kB]
    Des:4 http://ppa.launchpad.net karmic/main openoffice.org-java-common 1:3.2.0-4ubuntu0ppa1 [4.285kB]
    Des:5 http://ppa.launchpad.net karmic/main openoffice.org-filter-mobiledev 1:3.2.0-4ubuntu0ppa1 [93,0kB]
    Des:6 http://ppa.launchpad.net karmic/main openoffice.org-report-builder-bin 1:3.2.0-4ubuntu0ppa1 [2.157kB]
    Des:7 http://ppa.launchpad.net karmic/main ttf-opensymbol 1:3.2.0-4ubuntu0ppa1 [1.483kB]
    Descargados 13,0MB en 3min 37s (59,6kB/s)
    Preconfigurando paquetes …
    (Leyendo la base de datos … 00%
    190118 ficheros y directorios instalados actualmente.)
    Preparando para reemplazar ure 1.5.1+OOo3.1.1-5ubuntu1.1 (usando …/ure_1.6.0+OOo3.2.0-4ubuntu0ppa1_i386.deb) …
    Desempaquetando el reemplazo de ure …
    Preparando para reemplazar uno-libs3 1.5.1+OOo3.1.1-5ubuntu1.1 (usando …/uno-libs3_1.6.0+OOo3.2.0-4ubuntu0ppa1_i386.deb) …
    Desempaquetando el reemplazo de uno-libs3 …
    Preparando para reemplazar openoffice.org-emailmerge 1:3.1.1-5ubuntu1.1 (usando …/openoffice.org-emailmerge_1%3a3.2.0-4ubuntu0ppa1_all.deb) …

    ERROR: Couldn’t open registry file:///usr/lib/openoffice/basis3.1/program/offapi.rdb for reading

    unopkg failed.

    ERROR: Couldn’t open registry file:///usr/lib/openoffice/basis3.1/program/offapi.rdb for reading
    Exception details:
    (com.sun.star.registry.InvalidRegistryException) { { Message = “Couldn’t open registry file:///usr/lib/openoffice/basis3.1/program/offapi.rdb for reading”, Context = (com.sun.star.uno.XInterface) @0 } }

    unopkg failed.
    Desempaquetando el reemplazo de openoffice.org-emailmerge …
    Preparando para reemplazar openoffice.org-java-common 1:3.1.1-5ubuntu1.1 (usando …/openoffice.org-java-common_1%3a3.2.0-4ubuntu0ppa1_all.deb) …
    Desempaquetando el reemplazo de openoffice.org-java-common …
    Preparando para reemplazar openoffice.org-filter-mobiledev 1:3.1.1-5ubuntu1.1 (usando …/openoffice.org-filter-mobiledev_1%3a3.2.0-4ubuntu0ppa1_all.deb) …
    Desempaquetando el reemplazo de openoffice.org-filter-mobiledev …
    Preparando para reemplazar openoffice.org-report-builder-bin 1:3.1.1-5ubuntu1.1 (usando …/openoffice.org-report-builder-bin_1%3a3.2.0-4ubuntu0ppa1_i386.deb) …
    Desempaquetando el reemplazo de openoffice.org-report-builder-bin …
    Preparando para reemplazar ttf-opensymbol 1:3.1.1-5ubuntu1.1 (usando …/ttf-opensymbol_1%3a3.2.0-4ubuntu0ppa1_all.deb) …
    Desempaquetando el reemplazo de ttf-opensymbol …
    Configurando uno-libs3 (1.6.0+OOo3.2.0-4ubuntu0ppa1) …

    Configurando ure (1.6.0+OOo3.2.0-4ubuntu0ppa1) …
    Configurando openoffice.org-emailmerge (1:3.2.0-4ubuntu0ppa1) …

    ERROR: Couldn’t open registry file:///usr/lib/openoffice/basis3.1/program/offapi.rdb for reading
    Exception details:
    (com.sun.star.registry.InvalidRegistryException) { { Message = “Couldn’t open registry file:///usr/lib/openoffice/basis3.1/program/offapi.rdb for reading”, Context = (com.sun.star.uno.XInterface) @0 } }

    unopkg failed.

    Configurando openoffice.org-java-common (1:3.2.0-4ubuntu0ppa1) …

    Configurando openoffice.org-filter-mobiledev (1:3.2.0-4ubuntu0ppa1) …

    Configurando openoffice.org-report-builder-bin (1:3.2.0-4ubuntu0ppa1) …
    Configurando ttf-opensymbol (1:3.2.0-4ubuntu0ppa1) …
    Procesando disparadores para libc-bin …
    ldconfig deferred processing now taking place

  4. Lucas dice:

    Ahí pude instalar la versión 3.2 de OpenOffice. Era la opción más simple: hay que ir al Centro de Software de Ubuntu (teniendo la versión 3.1 instalada), le das openoffice a la búsqueda, te va aparecer al final la Suite de oficina de OpenOffice.org, le das click luego actualizar y listo! Más fácil imposible. 🙂

  5. […] algunos ayeres, les hablé sobre cómo actualizarse a la más nueva versión de OpenOffice (la 3.2.0) en Ubuntu, pues bien hoy estaba en mis labores cotidianas cuando decidí abrir el OpenOffice en la Beta 2 de […]

  6. JImmyCruz dice:

    Gracias, por tu ayuda, solo me falto reiniciar la maquina y lo hice.
    Gracias.

    PD Tengo Ubuntu 9.10 por que el 10.04 no da para netbook toshiba nb200

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s